summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-07-27 22:35:15 +0200
committerBram Moolenaar <Bram@vim.org>2018-07-27 22:35:15 +0200
commitd2a054910bf8f0888fac81e46a64a22dd4a763b5 (patch)
treec7d6a6b92751f31f333ba3d99bb75b298bf9bc7e /src/configure.ac
parent83ec2a7f5fb481b30a5d556b6aad49a62585bccd (diff)
patch 8.1.0215: no error if configure --with-x cannot configure Xv8.1.0215
Problem: No error if configure --with-x cannot configure X. Solution: Check that when --with-x is used X can be configured.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 107c170ecb..0d8ea32d34 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -72,6 +72,9 @@ AC_ARG_ENABLE(fail_if_missing,
[fail_if_missing="no"])
AC_MSG_RESULT($fail_if_missing)
+dnl Keep original value to check later.
+with_x_arg="$with_x"
+
dnl Set default value for CFLAGS if none is defined or it's empty
if test -z "$CFLAGS"; then
CFLAGS="-O"
@@ -2283,6 +2286,11 @@ else
fi
fi
+dnl Check if --with-x was given but it doesn't work.
+if test "x$with_x" = xno -a "x$with_x_arg" = xyes; then
+ AC_MSG_ERROR([could not configure X])
+fi
+
test "x$with_x" = xno -a "x$MACOS_X" != "xyes" -a "x$QNX" != "xyes" && enable_gui=no
AC_MSG_CHECKING(--enable-gui argument)