summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-12-30 22:55:47 +0100
committerBram Moolenaar <Bram@vim.org>2018-12-30 22:55:47 +0100
commitaf0839acec403379627a4bc50cbeca588344cea5 (patch)
tree285e6ff13bf503a0945b8618984235b86bf2319e /src/configure.ac
parent8caa10a8ec6e398fd67c30b8a2bf20638d3c6c0a (diff)
patch 8.1.0664: configure "fail-if-missing" does not apply to enable-guiv8.1.0664
Problem: Configure "fail-if-missing" does not apply to the enable-gui argument. (Rhialto) Solution: Make configure fail if a GUI was specifified and "fail-if-missing" is enabled and the GUI test fails.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/configure.ac b/src/configure.ac
index b256a87aae..700cd3e73c 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2366,8 +2366,8 @@ if test "x$QNX" = "xyes" -a "x$with_x" = "xno" ; then
case "$enable_gui_canon" in
no) AC_MSG_RESULT(no GUI support)
SKIP_PHOTON=YES ;;
- yes|"") AC_MSG_RESULT(yes - automatic GUI support) ;;
- auto) AC_MSG_RESULT(auto - automatic GUI support) ;;
+ yes|""|auto) AC_MSG_RESULT(automatic GUI support)
+ gui_auto=yes ;;
photon) AC_MSG_RESULT(Photon GUI support) ;;
*) AC_MSG_RESULT([Sorry, $enable_gui GUI is not supported])
SKIP_PHOTON=YES ;;
@@ -2378,7 +2378,8 @@ elif test "x$MACOS_X" = "xyes" -a "x$with_x" = "xno" ; then
case "$enable_gui_canon" in
no) AC_MSG_RESULT(no GUI support)
SKIP_CARBON=YES ;;
- yes|"") AC_MSG_RESULT(yes - automatic GUI support) ;;
+ yes|"") AC_MSG_RESULT(yes - automatic GUI support)
+ gui_auto=yes ;;
auto) AC_MSG_RESULT(auto - Carbon GUI is outdated - disable GUI support)
SKIP_CARBON=YES ;;
carbon) AC_MSG_RESULT(Carbon GUI support) ;;
@@ -2391,6 +2392,7 @@ else
case "$enable_gui_canon" in
no|none) AC_MSG_RESULT(no GUI support) ;;
yes|""|auto) AC_MSG_RESULT(yes/auto - automatic GUI support)
+ gui_auto=yes
SKIP_GTK2=
SKIP_GNOME=
SKIP_MOTIF=
@@ -2638,6 +2640,9 @@ return 1;
GTK_CFLAGS=""
GTK_LIBS=""
ifelse([$3], , :, [$3])
+ if test "$fail_if_missing" = "yes" -a "X$gui_auto" != "Xyes"; then
+ AC_MSG_ERROR([could not configure GTK])
+ fi
}
fi
}