summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-12-21 11:48:51 +0100
committerBram Moolenaar <Bram@vim.org>2018-12-21 11:48:51 +0100
commit9d302ad4e31b4e20ce0b3af700f43edb6f5e6036 (patch)
treebf98d94b2534ef89d8287a9f18a13110937a1e22 /src/configure.ac
parenta79fd56923744e331b3a5badbf9186100818fb45 (diff)
patch 8.1.0612: cannot use two global runtime dirs with configurev8.1.0612
Problem: Cannot use two global runtime dirs with configure. Solution: Support a comma in --with-global-runtime. (James McCoy, closes #3704)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index c97603a716..b256a87aae 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -345,10 +345,16 @@ AC_ARG_WITH(view-name, [ --with-view-name=NAME what to call the View executab
AC_SUBST(VIEWNAME)
AC_MSG_CHECKING(--with-global-runtime argument)
-AC_ARG_WITH(global-runtime, [ --with-global-runtime=DIR global runtime directory in 'runtimepath'],
- AC_MSG_RESULT($withval); AC_DEFINE_UNQUOTED(RUNTIME_GLOBAL, "$withval"),
+AC_ARG_WITH(global-runtime, [ --with-global-runtime=DIR global runtime directory in 'runtimepath', comma-separated for multiple directories],
+ RUNTIME_GLOBAL="$withval"; AC_MSG_RESULT($withval),
AC_MSG_RESULT(no))
+if test "X$RUNTIME_GLOBAL" != "X"; then
+ RUNTIME_GLOBAL_AFTER=$(printf -- "$RUNTIME_GLOBAL\\n" | $AWK -F, 'BEGIN { comma=0 } { for (i = NF; i > 0; i--) { if (comma) { printf ",%s/after", $i } else { printf "%s/after", $i; comma=1 } } } END { printf "\n" }')
+ AC_DEFINE_UNQUOTED(RUNTIME_GLOBAL, "$RUNTIME_GLOBAL")
+ AC_DEFINE_UNQUOTED(RUNTIME_GLOBAL_AFTER, "$RUNTIME_GLOBAL_AFTER")
+fi
+
AC_MSG_CHECKING(--with-modified-by argument)
AC_ARG_WITH(modified-by, [ --with-modified-by=NAME name of who modified a release version],
AC_MSG_RESULT($withval); AC_DEFINE_UNQUOTED(MODIFIED_BY, "$withval"),