summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-08-11 21:58:20 +0200
committerBram Moolenaar <Bram@vim.org>2020-08-11 21:58:20 +0200
commit097148e849136b49052b1b5123c714fb1d74db9b (patch)
treed5b0bf4ce9b435be94de3ff7b87e85ae99c1e484 /src/configure.ac
parent4301a729eabafee388aaf8465cf780d3f84cec95 (diff)
patch 8.2.1422: the Mac GUI implementation is outdatedv8.2.1422
Problem: The Mac GUI implementation is outdated and probably doesn't even work. Solution: Remove the Mac GUI code. The MacVim project provides the supported Vim GUI version.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac82
1 files changed, 2 insertions, 80 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 054ea1dcb8..8a5216a8a3 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -262,16 +262,6 @@ if test "`(uname) 2>/dev/null`" = Darwin; then
dnl TODO: use -arch i386 on Intel machines
dnl Removed -no-cpp-precomp, only for very old compilers.
CPPFLAGS="$CPPFLAGS -DMACOS_X_DARWIN"
-
- dnl If Carbon is found, assume we don't want X11
- dnl unless it was specifically asked for (--with-x)
- dnl or Motif, Athena or GTK GUI is used.
- AC_CHECK_HEADER(Carbon/Carbon.h, CARBON=yes)
- if test "x$CARBON" = "xyes"; then
- if test -z "$with_x" -a "X$enable_gui" != Xmotif -a "X$enable_gui" != Xathena -a "X$enable_gui" != Xgtk2 -a "X$enable_gui" != Xgtk3; then
- with_x=no
- fi
- fi
fi
dnl Avoid a bug with -O2 with gcc 4.0.1. Symptom: malloc() reports double
@@ -2406,7 +2396,6 @@ SKIP_ATHENA=YES
SKIP_NEXTAW=YES
SKIP_PHOTON=YES
SKIP_HAIKU=YES
-SKIP_CARBON=YES
GUITYPE=NONE
if test "x$HAIKU" = "xyes"; then
@@ -2432,20 +2421,6 @@ elif test "x$QNX" = "xyes" -a "x$with_x" = "xno" ; then
SKIP_PHOTON=YES ;;
esac
-elif test "x$MACOS_X" = "xyes" -a "x$with_x" = "xno" ; then
- SKIP_CARBON=
- case "$enable_gui_canon" in
- no) AC_MSG_RESULT(no GUI support)
- SKIP_CARBON=YES ;;
- yes|"") AC_MSG_RESULT(yes - automatic GUI support)
- gui_auto=yes ;;
- auto) AC_MSG_RESULT(auto - Carbon GUI is outdated - disable GUI support)
- SKIP_CARBON=YES ;;
- carbon) AC_MSG_RESULT(Carbon GUI support) ;;
- *) AC_MSG_RESULT([Sorry, $enable_gui GUI is not supported])
- SKIP_CARBON=YES ;;
- esac
-
else
case "$enable_gui_canon" in
@@ -2456,8 +2431,7 @@ else
SKIP_GNOME=
SKIP_MOTIF=
SKIP_ATHENA=
- SKIP_NEXTAW=
- SKIP_CARBON=;;
+ SKIP_NEXTAW=;;
gtk2) AC_MSG_RESULT(GTK+ 2.x GUI support)
SKIP_GTK2=;;
gnome2) AC_MSG_RESULT(GNOME 2.x GUI support)
@@ -2544,52 +2518,6 @@ if test "x$SKIP_NEXTAW" != "xYES" -a "$enable_gui_canon" != "nextaw"; then
fi
fi
-if test "x$SKIP_CARBON" != "xYES" -a "$enable_gui_canon" != "carbon"; then
- AC_MSG_CHECKING(whether or not to look for Carbon)
- AC_ARG_ENABLE(carbon-check,
- [ --enable-carbon-check If auto-select GUI, check for Carbon [default=yes]],
- , enable_carbon_check="yes")
- AC_MSG_RESULT($enable_carbon_check);
- if test "x$enable_carbon_check" = "xno"; then
- SKIP_CARBON=YES
- fi
-fi
-
-
-if test "x$MACOS_X" = "xyes" -a -z "$SKIP_CARBON" -a "x$CARBON" = "xyes"; then
- AC_MSG_CHECKING(for Carbon GUI)
- dnl already did the check, just give the message
- AC_MSG_RESULT(yes);
- GUITYPE=CARBONGUI
- if test "$VIMNAME" = "vim"; then
- VIMNAME=Vim
- fi
-
- if test "x$MACARCH" = "xboth"; then
- CPPFLAGS="$CPPFLAGS -I$DEVELOPER_DIR/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon"
- else
- CPPFLAGS="$CPPFLAGS -I$DEVELOPER_DIR/Headers/FlatCarbon"
- fi
-
- dnl Default install directory is not /usr/local
- if test x$prefix = xNONE; then
- prefix=/Applications
- fi
-
- dnl Sorry for the hard coded default
- datadir='${prefix}/Vim.app/Contents/Resources'
-
- dnl skip everything else
- SKIP_GTK2=YES;
- SKIP_GNOME=YES;
- SKIP_MOTIF=YES;
- SKIP_ATHENA=YES;
- SKIP_NEXTAW=YES;
- SKIP_PHOTON=YES;
- SKIP_HAIKU=YES;
- SKIP_CARBON=YES
-fi
-
dnl define an autoconf function to check for a specified version of GTK, and
dnl try to compile/link a GTK program.
dnl
@@ -4454,10 +4382,7 @@ fi
if test "$MACOS_X" = "yes"; then
AC_MSG_CHECKING([whether we need macOS frameworks])
- if test "$GUITYPE" = "CARBONGUI"; then
- AC_MSG_RESULT([yes, we need Carbon])
- LIBS="$LIBS -framework Carbon"
- elif test "$MACOS_X_DARWIN" = "yes"; then
+ if test "$MACOS_X_DARWIN" = "yes"; then
if test "$features" = "tiny"; then
dnl Since no FEAT_CLIPBOARD, no longer need for os_macosx.m.
OS_EXTRA_SRC=`echo "$OS_EXTRA_SRC" | sed -e 's+os_macosx.m++'`
@@ -4472,9 +4397,6 @@ if test "$MACOS_X" = "yes"; then
AC_MSG_RESULT([no])
fi
fi
-if test "x$MACARCH" = "xboth" && test "x$GUITYPE" = "xCARBONGUI"; then
- LDFLAGS="$LDFLAGS -isysroot $DEVELOPER_DIR/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc"
-fi
dnl gcc 3.1 changed the meaning of -MM. The only solution appears to be to
dnl use "-isystem" instead of "-I" for all non-Vim include dirs.