summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-05-02 18:14:37 +0200
committerBram Moolenaar <Bram@vim.org>2020-05-02 18:14:37 +0200
commit01f731e97c92bee05927f5008b7cd34ce188632b (patch)
tree6dbf63e95bc35da3f33fb358c88c083dcac123bd /src/configure.ac
parentbf67ea1af05cbb30cd8f0b665fb567c0dca79796 (diff)
patch 8.2.0680: PTYGROUP and PTYMODE are unusedv8.2.0680
Problem: PTYGROUP and PTYMODE are unused. Solution: Remove from autoconf. (closes #6024)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac71
1 files changed, 0 insertions, 71 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 2037de74fa..687bdf95d2 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3673,77 +3673,6 @@ else
AC_MSG_RESULT([don't know])
fi
-dnl **** pty mode/group handling ****
-dnl
-dnl support provided by Luke Mewburn <lm@rmit.edu.au>, 931222
-rm -f conftest_grp
-AC_CACHE_CHECK([default tty permissions/group], [vim_cv_tty_group],
- [
- AC_RUN_IFELSE([AC_LANG_SOURCE([[
-#include "confdefs.h"
-#include <sys/types.h>
-#if STDC_HEADERS
-# include <stdlib.h>
-# include <stddef.h>
-#endif
-#ifdef HAVE_UNISTD_H
-#include <unistd.h>
-#endif
-#include <sys/stat.h>
-#include <stdio.h>
-main()
-{
- struct stat sb;
- char *x,*ttyname();
- int om, m;
- FILE *fp;
-
- if (!(x = ttyname(0))) exit(1);
- if (stat(x, &sb)) exit(1);
- om = sb.st_mode;
- if (om & 002) exit(0);
- m = system("mesg y");
- if (m == -1 || m == 127) exit(1);
- if (stat(x, &sb)) exit(1);
- m = sb.st_mode;
- if (chmod(x, om)) exit(1);
- if (m & 002) exit(0);
- if (sb.st_gid == getgid()) exit(1);
- if (!(fp=fopen("conftest_grp", "w")))
- exit(1);
- fprintf(fp, "%d\n", sb.st_gid);
- fclose(fp);
- exit(0);
-}
- ]])],[
- if test -f conftest_grp; then
- vim_cv_tty_group=`cat conftest_grp`
- if test "x$vim_cv_tty_mode" = "x" ; then
- vim_cv_tty_mode=0620
- fi
- AC_MSG_RESULT([pty mode: $vim_cv_tty_mode, group: $vim_cv_tty_group])
- else
- vim_cv_tty_group=world
- AC_MSG_RESULT([ptys are world accessible])
- fi
- ],[
- vim_cv_tty_group=world
- AC_MSG_RESULT([can't determine - assume ptys are world accessible])
- ],[
- AC_MSG_ERROR(cross-compiling: please set 'vim_cv_tty_group' and 'vim_cv_tty_mode')
- ])
- ])
-rm -f conftest_grp
-
-if test "x$vim_cv_tty_group" != "xworld" ; then
- AC_DEFINE_UNQUOTED(PTYGROUP,$vim_cv_tty_group)
- if test "x$vim_cv_tty_mode" = "x" ; then
- AC_MSG_ERROR([It seems you're cross compiling and have 'vim_cv_tty_group' set, please also set the environment variable 'vim_cv_tty_mode' to the correct mode (probably 0620)])
- else
- AC_DEFINE(PTYMODE, 0620)
- fi
-fi
-
dnl Checks for library functions. ===================================
AC_TYPE_SIGNAL