summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2017-09-03 19:15:57 +0200
committerBram Moolenaar <Bram@vim.org>2017-09-03 19:15:57 +0200
commit595a40226ea1285689b622042534fd8442402db3 (patch)
tree9ad063cf0aaf7f073131116e42d59ab5dfda9089 /src/configure.ac
parentd8d85bfb7d650d2fb584ea48aaaebdbc8a2e3dce (diff)
patch 8.0.1050: terminal window feature not included by defaultv8.0.1050
Problem: Terminal window feature not included by default. Solution: Include the terminal feature for the "huge" build.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ea4df8f0ea..918c36c1da 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2031,16 +2031,26 @@ fi
AC_MSG_CHECKING(--enable-terminal argument)
AC_ARG_ENABLE(terminal,
[ --enable-terminal Enable terminal emulation support.],
- [enable_terminal="yes"], )
-if test "$enable_terminal" = "yes"; then
+ [enable_terminal="yes"], [enable_terminal="auto"])
+if test "$enable_terminal" = "yes" || test "$enable_terminal" = "auto" -a "x$features" = "xhuge" ; then
if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
AC_MSG_RESULT([cannot use terminal emulator with tiny or small features])
enable_terminal="no"
else
- AC_MSG_RESULT(yes)
+ if test "$enable_terminal" = "auto"; then
+ enable_terminal="yes"
+ AC_MSG_RESULT(defaulting to yes)
+ else
+ AC_MSG_RESULT(yes)
+ fi
fi
else
- AC_MSG_RESULT(no)
+ if test "$enable_terminal" = "auto"; then
+ enable_terminal="no"
+ AC_MSG_RESULT(defaulting to no)
+ else
+ AC_MSG_RESULT(no)
+ fi
fi
if test "$enable_terminal" = "yes"; then
AC_DEFINE(FEAT_TERMINAL)