summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2017-09-27 21:42:08 +0200
committerBram Moolenaar <Bram@vim.org>2017-09-27 21:42:08 +0200
commit1ec96c926974208bd47710384c8202c47d0752d0 (patch)
tree5c2cd9d9f8578d9d0d67341eaf41dfdf301ab4db /src/configure.ac
parentd1bc96ce2466ac1b4af4a2c36de455a1df318d1d (diff)
patch 8.0.1156: trouble from removing one -W argument from Perl CFLAGSv8.0.1156
Problem: Removing one -W argument from Perl CFLAGS may cause trouble. Solution: Remove all -W flags. (Christian Brabandt)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 1183ab44b6..76714b1e7b 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1006,10 +1006,13 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
dnl Remove "-fno-something", it breaks using cproto.
dnl Remove "-fdebug-prefix-map", it isn't supported by clang.
dnl Remove "FORTIFY_SOURCE", it will be defined twice.
+ dnl remove -pipe and -Wxxx, it confuses cproto
perlcppflags=`$vi_cv_path_perl -Mlib=$srcdir -MExtUtils::Embed \
-e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//' \
-e 's/-fdebug-prefix-map[[^ ]]*//g' \
- -e 's/\(-Wp,\)\?-D_FORTIFY_SOURCE=.//g'`
+ -e 's/-pipe //' \
+ -e 's/-W[[^ ]]*//g' \
+ -e 's/-D_FORTIFY_SOURCE=.//g'`
dnl Remove "-lc", it breaks on FreeBSD when using "-pthread".
perllibs=`cd $srcdir; $vi_cv_path_perl -MExtUtils::Embed -e 'ldopts' | \
sed -e '/Warning/d' -e '/Note (probably harmless)/d' \
@@ -1037,8 +1040,7 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
LDFLAGS=$ldflags_save
if test $perl_ok = yes; then
if test "X$perlcppflags" != "X"; then
- dnl remove -pipe and -Wxxx, it confuses cproto
- PERL_CFLAGS=`echo "$perlcppflags" | sed -e 's/-pipe //' -e 's/-W[[^ ]]*//'`
+ PERL_CFLAGS=$perlcppflags
fi
if test "X$perlldflags" != "X"; then
if test "X`echo \"$LDFLAGS\" | $FGREP -e \"$perlldflags\"`" = "X"; then