summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2022-01-18 11:11:25 +0000
committerBram Moolenaar <Bram@vim.org>2022-01-18 11:11:25 +0000
commit1247126956c2ba666048b2bf99630eef7495e98e (patch)
tree0611422f3cba2c572e92efb3661925b32d7ccfbb /src/configure.ac
parent64283d5e1f5487e2dbaa17d478e6eae040daa064 (diff)
patch 8.2.4129: building with +sound but without +eval failsv8.2.4129
Problem: Building with +sound but without +eval fails. (Dominique Pellé) Solution: Disable canberra in tiny and small build. (closes #9548)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac31
1 files changed, 21 insertions, 10 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 86f70f581c..67b376a49e 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -540,6 +540,12 @@ esac
AC_SUBST(dovimdiff)
AC_SUBST(dogvimdiff)
+if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ has_eval=no
+else
+ has_eval=yes
+fi
+
AC_MSG_CHECKING(--with-compiledby argument)
AC_ARG_WITH(compiledby, [ --with-compiledby=NAME name to show in :version message],
compiledby="$withval"; AC_MSG_RESULT($withval),
@@ -585,7 +591,7 @@ AC_ARG_ENABLE(luainterp,
AC_MSG_RESULT($enable_luainterp)
if test "$enable_luainterp" = "yes" -o "$enable_luainterp" = "dynamic"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_ERROR([cannot use Lua with tiny or small features])
fi
@@ -1072,7 +1078,7 @@ AC_ARG_ENABLE(perlinterp,
[enable_perlinterp="no"])
AC_MSG_RESULT($enable_perlinterp)
if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_ERROR([cannot use Perl with tiny or small features])
fi
AC_SUBST(vi_cv_path_perl)
@@ -1221,7 +1227,7 @@ AC_ARG_ENABLE(pythoninterp,
[enable_pythoninterp="no"])
AC_MSG_RESULT($enable_pythoninterp)
if test "$enable_pythoninterp" = "yes" -o "$enable_pythoninterp" = "dynamic"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_ERROR([cannot use Python with tiny or small features])
fi
@@ -1456,7 +1462,7 @@ AC_ARG_ENABLE(python3interp,
[enable_python3interp="no"])
AC_MSG_RESULT($enable_python3interp)
if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_ERROR([cannot use Python with tiny or small features])
fi
@@ -1969,7 +1975,7 @@ AC_ARG_ENABLE(rubyinterp,
[enable_rubyinterp="no"])
AC_MSG_RESULT($enable_rubyinterp)
if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_ERROR([cannot use Ruby with tiny or small features])
fi
@@ -2082,7 +2088,7 @@ AC_ARG_ENABLE(netbeans,
[ --disable-netbeans Disable NetBeans integration support.],
, [enable_netbeans="yes"])
if test "$enable_netbeans" = "yes"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_RESULT([cannot use NetBeans with tiny or small features])
enable_netbeans="no"
else
@@ -2097,7 +2103,7 @@ AC_ARG_ENABLE(channel,
[ --disable-channel Disable process communication support.],
, [enable_channel="yes"])
if test "$enable_channel" = "yes"; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_RESULT([cannot use channels with tiny or small features])
enable_channel="no"
else
@@ -2205,7 +2211,7 @@ AC_ARG_ENABLE(terminal,
[ --enable-terminal Enable terminal emulation support.],
, [enable_terminal="auto"])
if test "$enable_terminal" = "yes" || test "$enable_terminal" = "auto" -a "x$features" = "xhuge" ; then
- if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+ if test "$has_eval" = "no"; then
AC_MSG_RESULT([cannot use terminal emulator with tiny or small features])
enable_terminal="no"
else
@@ -3794,7 +3800,12 @@ if test "$enable_canberra" = "maybe"; then
enable_canberra="no"
fi
else
- AC_MSG_RESULT($enable_canberra)
+ if test "$enable_canberra" = "yes" -a "$has_eval" = "no"; then
+ AC_MSG_RESULT([cannot use sound with tiny or small features])
+ enable_canberra="no"
+ else
+ AC_MSG_RESULT($enable_canberra)
+ fi
fi
if test "$enable_canberra" = "yes"; then
if test "x$PKG_CONFIG" != "xno"; then
@@ -3808,7 +3819,7 @@ if test "$enable_canberra" = "yes"; then
AC_MSG_CHECKING(for libcanberra)
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
- if `echo "$CFLAGS" | grep -v "$canberra_cflags" >/dev/null`; then
+ if `echo "$CFLAGS" | grep -v "$canberra_cflags" 2>/dev/null`; then
CFLAGS="$CFLAGS $canberra_cflags"
fi
LIBS="$LIBS $canberra_lib"