summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-11-26 20:11:11 +0100
committerBram Moolenaar <Bram@vim.org>2020-11-26 20:11:11 +0100
commitce7be3a0e6f19bc85990bb8fcfe5e208944777b4 (patch)
tree05f693e575be40068c6ced92e0fd72f8e2e49264 /src/configure.ac
parent2472a74be4dedfeaff22314f31cf9787618163d1 (diff)
patch 8.2.2056: configure fails when building with implicit-function-declarationv8.2.2056
Problem: Configure fails when building with the "implicit-function-declaration" error enabled, specifically on Mac. Solution: Declear the functions like in the source code. (suggestion by Clemens Lang, closes #7380)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 457f2b82b1..010cc8f09c 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3593,7 +3593,15 @@ fi
AC_MSG_CHECKING(for SVR4 ptys)
if test -c /dev/ptmx ; then
- AC_TRY_LINK([], [ptsname(0);grantpt(0);unlockpt(0);],
+ AC_TRY_LINK([
+// These should be in stdlib.h, but it depends on _XOPEN_SOURCE.
+char *ptsname(int);
+int unlockpt(int);
+int grantpt(int);
+ ], [
+ ptsname(0);
+ grantpt(0);
+ unlockpt(0);],
AC_MSG_RESULT(yes); AC_DEFINE(HAVE_SVR4_PTYS),
AC_MSG_RESULT(no))
else