summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-07-28 21:03:37 +0200
committerBram Moolenaar <Bram@vim.org>2020-07-28 21:03:37 +0200
commitbd7f7c123db58dd7f50f4d1391577686d2f1bcc6 (patch)
tree4e7a5662cd144de1f49cf9a012e7b469428c9466 /src/configure.ac
parent461f21242a8fc7f2fe9d1c723741eeda45f0ac72 (diff)
patch 8.2.1310: configure with Xcode 12 fails to check for tgetentv8.2.1310
Problem: Configure with Xcode 12 fails to check for tgetent. Solution: Declare tgetent(). (Ozaki Kiichi, closes #6558)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 19ce4c7a5f..598d73c8df 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3510,7 +3510,7 @@ fi
if test "x$olibs" = "x$LIBS"; then
AC_MSG_CHECKING([for tgetent()])
- AC_TRY_LINK([],
+ AC_TRY_LINK([int tgetent(char *, const char *);],
[char s[10000]; int res = tgetent(s, "thisterminaldoesnotexist");],
AC_MSG_RESULT(yes),
AC_MSG_ERROR([NOT FOUND!