summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-05-07 18:37:03 +0200
committerBram Moolenaar <Bram@vim.org>2020-05-07 18:37:03 +0200
commitb2d0e51366dea6843f991f31a457f5456d162678 (patch)
treec220d988cb585427bf0e4eae0fc648ec3d0524d5 /src/configure.ac
parent4a070cc82e00618db279526797564cb2b4e9b060 (diff)
patch 8.2.0711: temp directory might be clearedv8.2.0711
Problem: With a long running Vim the temp directory might be cleared on some systems. Solution: Lock the temp directory. (closes #6044)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 687bdf95d2..8751b2e63b 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4060,6 +4060,21 @@ AC_TRY_LINK([#include <stdio.h>], [rename("this", "that")],
AC_MSG_RESULT(yes); AC_DEFINE(HAVE_RENAME),
AC_MSG_RESULT(no))
+dnl check for dirfd()
+AC_MSG_CHECKING(for dirfd)
+AC_TRY_COMPILE(
+[#include <sys/types.h>
+#include <dirent.h>],
+[DIR * dir=opendir("dirname"); dirfd(dir);],
+AC_MSG_RESULT(yes); AC_DEFINE(HAVE_DIRFD), AC_MSG_RESULT(not usable))
+
+dnl check for flock()
+AC_MSG_CHECKING(for flock)
+AC_TRY_COMPILE(
+[#include <sys/file.h>],
+[flock(10, LOCK_SH);],
+AC_MSG_RESULT(yes); AC_DEFINE(HAVE_FLOCK), AC_MSG_RESULT(not usable))
+
dnl sysctl() may exist but not the arguments we use
AC_MSG_CHECKING(for sysctl)
AC_TRY_COMPILE(