summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2017-10-12 12:33:43 +0200
committerBram Moolenaar <Bram@vim.org>2017-10-12 12:33:43 +0200
commit9202162c5c069c925b6b9bf84e546fbd362cdf46 (patch)
tree7e6c64a6b068ba888c14fdde4ca595fdd058c56d /src/configure.ac
parent9b69f22e66d51d764e9ade87ae8a57ac13ab7348 (diff)
patch 8.0.1185: Ruby library includes minor version numberv8.0.1185
Problem: Ruby library includes minor version number. Solution: Only use the API version number. (Ben Boeckel, closes #2199)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 76714b1e7b..f4650962bb 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1902,9 +1902,9 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
RUBY_PRO="if_ruby.pro"
AC_DEFINE(FEAT_RUBY)
if test "$enable_rubyinterp" = "dynamic"; then
- libruby=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_SO']]"`
+ libruby_soname=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_ALIASES']].split[[0]]"`
AC_DEFINE(DYNAMIC_RUBY)
- RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby\\\" -DDYNAMIC_RUBY_VER=$rubyversion $RUBY_CFLAGS"
+ RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby_soname\\\" -DDYNAMIC_RUBY_VER=$rubyversion $RUBY_CFLAGS"
RUBY_LIBS=
fi
else