summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2019-11-17 19:07:42 +0100
committerBram Moolenaar <Bram@vim.org>2019-11-17 19:07:42 +0100
commit91b992c38769b343b4a66a5f8e589aa9897fdc9f (patch)
treedab0af77605e0250a5a819e4c552107358ab548f /src/configure.ac
parent539aa6b25eaea91dfd1a175cd053c0f259fa2e58 (diff)
patch 8.1.2316: FORTIFY_SOURCE can also be present in CPPFLAGSv8.1.2316
Problem: FORTIFY_SOURCE can also be present in CPPFLAGS. Solution: Remove it in configure. (Benedikt Morbach, closes #2786)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index b59914b62e..4065817f34 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3789,7 +3789,7 @@ if test "$enable_canberra" = "yes"; then
ca_context *hello;
ca_context_create(&hello);],
AC_MSG_RESULT(yes); AC_DEFINE(HAVE_CANBERRA),
- AC_MSG_RESULT(no); CFLAGS="$ac_save_CFLAGS"; LIBS="$ac_save_LIBS")
+ AC_MSG_RESULT(no; try installing libcanberra-dev); CFLAGS="$ac_save_CFLAGS"; LIBS="$ac_save_LIBS")
fi
@@ -4482,6 +4482,7 @@ if test "$GCC" = yes; then
AC_MSG_CHECKING(whether we need -D_FORTIFY_SOURCE=1)
if test "$gccmajor" -gt "3"; then
CFLAGS=`echo "$CFLAGS" | sed -e 's/ *-Wp,-D_FORTIFY_SOURCE=.//g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g' -e 's/$/ -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1/'`
+ CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/ *-Wp,-D_FORTIFY_SOURCE=.//g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g'`
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)