summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-09-05 15:48:51 +0200
committerBram Moolenaar <Bram@vim.org>2020-09-05 15:48:51 +0200
commit8b5866ded6036f7adece26b6d16962bbd2d47842 (patch)
treea473e6759fd5a5dc6436a6502c0d51ddb077805a /src/configure.ac
parent7dfc5ce7cf4a7f63370d7dce2e13f7410ca0230a (diff)
patch 8.2.1597: the channel source file is too bigv8.2.1597
Problem: The channel source file is too big. Solution: Move job related code to a new source file.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 6176dc9ca5..d26299003a 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2143,9 +2143,9 @@ if test "$enable_netbeans" = "yes"; then
fi
if test "$enable_channel" = "yes"; then
AC_DEFINE(FEAT_JOB_CHANNEL)
- CHANNEL_SRC="channel.c"
+ CHANNEL_SRC="job.c channel.c"
AC_SUBST(CHANNEL_SRC)
- CHANNEL_OBJ="objects/channel.o"
+ CHANNEL_OBJ="objects/job.o objects/channel.o"
AC_SUBST(CHANNEL_OBJ)
fi