summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2017-12-16 14:37:06 +0100
committerBram Moolenaar <Bram@vim.org>2017-12-16 14:37:06 +0100
commit8b42328cef294a5d6059ee7c452da75b845f6f8c (patch)
tree5e4cdccbfcc5d366bad4b821efc5d13c6aa59bf5 /src/configure.ac
parentb29d328eb403a243431f4d0d5b360b4ac46bbc3e (diff)
patch 8.0.1392: build fails with --with-features=huge --disable-channelv8.0.1392
Problem: Build fails with --with-features=huge --disable-channel. Solution: Don't enable the terminal feature when the channel feature is missing. (Dominique Pelle, closes #2453)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d08986ed98..0883cb7d87 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2059,7 +2059,7 @@ else
AC_MSG_RESULT(no)
fi
fi
-if test "$enable_terminal" = "yes"; then
+if test "$enable_terminal" = "yes" -a "$enable_channel" = "yes"; then
AC_DEFINE(FEAT_TERMINAL)
TERM_SRC="libvterm/src/encoding.c libvterm/src/keyboard.c libvterm/src/mouse.c libvterm/src/parser.c libvterm/src/pen.c libvterm/src/screen.c libvterm/src/state.c libvterm/src/unicode.c libvterm/src/vterm.c"
AC_SUBST(TERM_SRC)