summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-12-28 21:36:56 +0100
committerBram Moolenaar <Bram@vim.org>2020-12-28 21:36:56 +0100
commit864a28b6a6ae4f1a56e230be26bc6d13e3f8b3d9 (patch)
treec1002abbe3cdce8579ff2a192ef46a0ee43ddbc3 /src/configure.ac
parent41a834d1e3dbf9c8759737bcd6524159a9b93d2a (diff)
patch 8.2.2241: Build with Ruby and clang may failv8.2.2241
Problem: Build with Ruby and clang may fail. Solution: Adjust congigure and sed script. (Ozaki Kiichi, closes #7566)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index c024f65216..d13e3783ce 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2001,6 +2001,9 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby_soname\\\" $RUBY_CFLAGS"
RUBY_LIBS=
fi
+ if test "X$CLANG_VERSION" != "X" -a "$rubyversion" -ge 30; then
+ RUBY_CFLAGS="$RUBY_CFLAGS -fdeclspec"
+ fi
else
AC_MSG_RESULT(not found; disabling Ruby)
fi