summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-12-04 18:09:54 +0100
committerBram Moolenaar <Bram@vim.org>2020-12-04 18:09:54 +0100
commit6cd42db9dc1251b052b97d47bafc063eacac1b3e (patch)
treec1702b00dc85a1303183f7136e098a346594c44f /src/configure.ac
parentf6c177ab3acda131d693f2cab0796df16da5b732 (diff)
patch 8.2.2089: libvterm test fails to build on Macv8.2.2089
Problem: Libvterm test fails to build on Mac. Solution: Adjust configure to remove a space between -L and the path that follows.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 010cc8f09c..4b6794a29e 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4467,6 +4467,10 @@ else
AC_MSG_RESULT(no)
fi
+dnl $LDFLAGS is passed to glibtool in libvterm, it doesn't like a space
+dnl between "-L" and the path that follows.
+LDFLAGS=`echo "$LDFLAGS" | sed -e 's/-L /-L/g'`
+
dnl link.sh tries to avoid overlinking in a hackish way.
dnl At least GNU ld supports --as-needed which provides the same functionality
dnl at linker level. Let's use it.