summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-12-12 20:34:09 +0100
committerBram Moolenaar <Bram@vim.org>2018-12-12 20:34:09 +0100
commit5c5697f29829fc3b21fc5452fe8f239f6a4cb8e1 (patch)
tree9c55dc06b8069bf990df87581ffe78cd87706d4d /src/configure.ac
parent295471920def98ce84bc96e5d97c16d250c81621 (diff)
patch 8.1.0578: cannot disable arabic, rightleft and farsi in configurev8.1.0578
Problem: Cannot disable arabic, rightleft and farsi in configure. Solution: Add configur flags. (Diego Fernando CarriĆ³n, closes #1867)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 2a31f41a43..c97603a716 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2138,6 +2138,45 @@ if test "$enable_multibyte" = "yes"; then
AC_DEFINE(FEAT_MBYTE)
fi
+dnl Right-to-Left language support for Vim will be included with big features,
+dnl unless ENABLE_RIGHTLEFT is undefined.
+AC_MSG_CHECKING(--disable-rightleft argument)
+AC_ARG_ENABLE(rightleft,
+ [ --disable-rightleft Do not include Right-to-Left language support.],
+ , [enable_rightleft="yes"])
+if test "$enable_rightleft" = "yes"; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(DISABLE_RIGHTLEFT)
+fi
+
+dnl Arabic language support for Vim will be included with big features,
+dnl unless ENABLE_ARABIC is undefined.
+AC_MSG_CHECKING(--disable-arabic argument)
+AC_ARG_ENABLE(arabic,
+ [ --disable-arabic Do not include Arabic language support.],
+ , [enable_arabic="yes"])
+if test "$enable_arabic" = "yes"; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(DISABLE_ARABIC)
+fi
+
+dnl Farsi language support for vim will be included with big features,
+dnl unless ENABLE_FARSI is undefined.
+AC_MSG_CHECKING(--disable-farsi argument)
+AC_ARG_ENABLE(farsi,
+ [ --disable-farsi Do not include Farsi language support.],
+ , [enable_farsi="yes"])
+if test "$enable_farsi" = "yes"; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(DISABLE_FARSI)
+fi
+
AC_MSG_CHECKING(--enable-hangulinput argument)
AC_ARG_ENABLE(hangulinput,
[ --enable-hangulinput Include Hangul input support.], ,