summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-01-02 22:38:49 +0100
committerBram Moolenaar <Bram@vim.org>2020-01-02 22:38:49 +0100
commit509ff0688df557155feb7312a0129428eb5d8fc1 (patch)
treeb14bc98386808f031a1e5312f2d6431540c9456b /src/configure.ac
parentd7df279808f75f7a4af8dd48deae73a9b727ac3b (diff)
patch 8.2.0080: globals using INIT4() are not in the tags filev8.2.0080
Problem: Globals using INIT4() are not in the tags file. Solution: Adjust the tags command.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/configure.ac b/src/configure.ac
index fd93b78227..d440a465ca 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4236,11 +4236,11 @@ dnl -i+m to test for older Exuberant ctags
AC_MSG_CHECKING(how to create tags)
test -f tags && mv tags tags.save
if (eval ctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
- TAGPRG="ctags -I INIT+ --fields=+S"
+ TAGPRG="ctags -I INIT+,INIT2+,INIT3+,INIT4+,INIT5+ --fields=+S"
elif (eval exctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
- TAGPRG="exctags -I INIT+ --fields=+S"
+ TAGPRG="exctags -I INIT+,INIT2+,INIT3+,INIT4+,INIT5+ --fields=+S"
elif (eval exuberant-ctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
- TAGPRG="exuberant-ctags -I INIT+ --fields=+S"
+ TAGPRG="exuberant-ctags -I INIT+,INIT2+,INIT3+,INIT4+,INIT5+ --fields=+S"
else
TAGPRG="ctags"
(eval etags /dev/null) < /dev/null 1>&AC_FD_CC 2>&1 && TAGPRG="etags"