summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2018-04-10 20:26:20 +0200
committerBram Moolenaar <Bram@vim.org>2018-04-10 20:26:20 +0200
commit3a21d9c7bb4d58cccd2152e319daa8f8ffa2e664 (patch)
tree1e6f1e24259c940e428151ef65a3f07661ee1b72 /src/configure.ac
parent164268d4cf84fa0efd984fddbef4a41366aabd46 (diff)
patch 8.0.1692: Python may not work when using statically linked libraryv8.0.1692
Problem: Python may not work when using statically linked library . Solution: Do not define PYTHON_HOME and PYTHON3_HOME in configure if the Python library is linked statically.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index e2867b422e..4e71de3312 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1255,7 +1255,7 @@ eof
else
PYTHON_CFLAGS="-I${vi_cv_path_python_pfx}/include/python${vi_cv_var_python_version} -I${vi_cv_path_python_epfx}/include/python${vi_cv_var_python_version}"
fi
- if test "X$have_python_config_dir" = "X1"; then
+ if test "X$have_python_config_dir" = "X1" -a "$enable_pythoninterp" = "dynamic"; then
dnl Define PYTHON_HOME if --with-python-config-dir was used
PYTHON_CFLAGS="${PYTHON_CFLAGS} -DPYTHON_HOME='\"${vi_cv_path_python_pfx}\"'"
@@ -1469,7 +1469,7 @@ eof
else
PYTHON3_CFLAGS="-I${vi_cv_path_python3_pfx}/include/python${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags} -I${vi_cv_path_python3_epfx}/include/python${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags}"
fi
- if test "X$have_python3_config_dir" = "X1"; then
+ if test "X$have_python3_config_dir" = "X1" -a "$enable_python3interp" = "dynamic"; then
dnl Define PYTHON3_HOME if --with-python-config-dir was used
PYTHON3_CFLAGS="${PYTHON3_CFLAGS} -DPYTHON3_HOME='L\"${vi_cv_path_python3_pfx}\"'"
fi