summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-02-07 20:50:07 +0100
committerBram Moolenaar <Bram@vim.org>2020-02-07 20:50:07 +0100
commit348808f7c000a49d435c15db68c814b026f8167d (patch)
tree302062ef2ccc2f33f9d62ab337614724cdb8aa7f /src/configure.ac
parentc2a4b35b86fa8b28a34a9aea8ad16c87dbc6d834 (diff)
patch 8.2.0228: configure does not recognize gcc version on BSDv8.2.0228
Problem: Configure does not recognize gcc version on BSD. Solution: Do not use "\+" in the pattern matching the version number. (Ozaki Kiichi, closes #5590)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index bf10eac551..fe2022802b 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4447,7 +4447,7 @@ dnl the number before the version number.
DEPEND_CFLAGS_FILTER=
if test "$GCC" = yes; then
AC_MSG_CHECKING(for GCC 3 or later)
- gccmajor=`echo "$gccversion" | sed -e 's/^\([[0-9]]\+\)\..*$/\1/g'`
+ gccmajor=`echo "$gccversion" | sed -e 's/^\([[1-9]][[0-9]]*\)\..*$/\1/g'`
if test "$gccmajor" -gt "2"; then
DEPEND_CFLAGS_FILTER="| sed 's+-I */+-isystem /+g'"
AC_MSG_RESULT(yes)