summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2023-03-31 21:29:00 +0100
committerBram Moolenaar <Bram@vim.org>2023-03-31 21:29:00 +0100
commit869113f3765d51fc822a61b2ba53d339797c1231 (patch)
tree1065e50878d5828e5a12a4b8df649ed49d0ff68b /src/configure.ac
parent6ac2e4392a9d8b89c8824bf94a9da24a6f07c74f (diff)
patch 9.0.1433: on some systems the Lua library is not foundv9.0.1433
Problem: On some systems the Lua library is not found. Solution: Check if a subdirectory for Lua exists. (closes #4475)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 13f5700d0f..94e186382d 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -716,11 +716,17 @@ if test "$enable_luainterp" = "yes" -o "$enable_luainterp" = "dynamic"; then
LUA_LIBS="-L${vi_cv_path_lua_pfx}/${lib_multiarch} -lluajit-$vi_cv_version_lua"
fi
else
+ dnl Test alternate lib location including version
+ if test -d "${vi_cv_path_lua_pfx}/lib/lua$vi_cv_version_lua"; then
+ LUALIBDIR="lib/lua$vi_cv_version_lua"
+ else
+ LUALIBDIR=lib
+ fi
if test "X$LUA_INC" != "X"; then
- dnl Test alternate location using version
- LUA_LIBS="-L${vi_cv_path_lua_pfx}/lib -llua$vi_cv_version_lua"
+ dnl Test alternate name including version
+ LUA_LIBS="-L${vi_cv_path_lua_pfx}/${LUALIBDIR} -llua$vi_cv_version_lua"
else
- LUA_LIBS="-L${vi_cv_path_lua_pfx}/lib -llua"
+ LUA_LIBS="-L${vi_cv_path_lua_pfx}/${LUALIBDIR} -llua"
fi
fi
if test "$enable_luainterp" = "dynamic"; then