summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorChristian Brabandt <cb@256bit.org>2024-02-12 23:12:26 +0100
committerChristian Brabandt <cb@256bit.org>2024-02-12 23:14:19 +0100
commit2f9aef42af94f6d68f37f6e9b8cb878e88ed12bf (patch)
tree257b645217b37e1f1f830afbfd7c0a76e686f503 /src/configure.ac
parentf0a9d65e0a1d693cdfa964aa72de5b93b4cacdea (diff)
patch 9.1.0104: Linking fails with -lto because of PERL_CFLAGSv9.1.0104
Problem: Linking fails with -lto because of PERL_CFLAGS (Zoltan Toth) Solution: Filter out -flto argument from Perl CFLAGS. fixes: #14012 Signed-off-by: Christian Brabandt <cb@256bit.org>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index ebe0d08f6e..664f219405 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1163,11 +1163,13 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
dnl Remove "-fno-something", it breaks using cproto.
dnl Remove "-fdebug-prefix-map", it isn't supported by clang.
dnl Remove "FORTIFY_SOURCE", it will be defined twice.
- dnl remove -pipe and -Wxxx, it confuses cproto
+ dnl Remove -pipe and -Wxxx, it confuses cproto
+ dnl Remove -flto[=auto], it causes link failures for clang
perlcppflags=`$vi_cv_path_perl -Mlib=$srcdir -MExtUtils::Embed \
-e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//' \
-e 's/-fdebug-prefix-map[[^ ]]*//g' \
-e 's/-pipe //' \
+ -e 's/-flto\(=auto\)\? //' \
-e 's/-W[[^ ]]*//g' \
-e 's/-D_FORTIFY_SOURCE=.//g'`
dnl Remove "-lc", it breaks on FreeBSD when using "-pthread".