summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2022-07-30 11:00:50 +0100
committerBram Moolenaar <Bram@vim.org>2022-07-30 11:00:50 +0100
commit5f6cae8b8a49c435556e32f84d067cd0b4d28e4c (patch)
treeafbbc0a280a61666137fdb031f71e69f339d6a37 /src/configure.ac
parent2ecbe53f452e92e941aff623f6a0b72f80e43d07 (diff)
patch 9.0.0108: configure check for timer_create may give wrong errorv9.0.0108
Problem: Configure check for timer_create may give wrong error. Solution: Give a warning instead of an error.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d777b052fd..76eb56327c 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3828,7 +3828,7 @@ static void set_flag(union sigval sv) {}
])],
vim_cv_timer_create=yes,
vim_cv_timer_create=no,
- AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create')
+ AC_MSG_WARN([failed to build test program; if cross-compiling please set 'vim_cv_timer_create'])
)])
dnl If the previous failed, check for timer_create() and linking with -lrt.
@@ -3856,7 +3856,7 @@ if test "x$vim_cv_timer_create" = "xno" ; then
])],
vim_cv_timer_create_with_lrt=yes,
vim_cv_timer_create_with_lrt=no,
- AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create_with_lrt')
+ AC_MSG_WARN([failed to build test program; if cross-compiling please set 'vim_cv_timer_create_with_lrt'])
)])
LIBS="$save_LIBS"
else