summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorZdenek Dohnal <zdohnal@redhat.com>2023-11-02 20:19:06 +0100
committerChristian Brabandt <cb@256bit.org>2023-11-02 20:19:06 +0100
commit1b1c9f272ddfa5f1d7d903cd9d59320cb97bfd4b (patch)
treec45b37137bc868a0b6f161f35bc0c047c5dccbd7 /src/configure.ac
parent2b89afd5eb63864154d973e7991a56a53b87a767 (diff)
patch 9.0.2083: Perl: xsubpp may be in non-standard locationv9.0.2083
Problem: Perl: xsubpp may be in non-standard location Solution: Add --with-subpp configure option configure.ac: Add --with-xsubpp configure option Some environments (such as flatpaks) cannot count on xsubpp being in the common Perl directory, so a configure option should be used for clean solution. closes: #13470 Signed-off-by: Zdenek Dohnal <zdohnal@redhat.com> Signed-off-by: Christian Brabandt <cb@256bit.org>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac33
1 files changed, 27 insertions, 6 deletions
diff --git a/src/configure.ac b/src/configure.ac
index dfbe512371..2ee9b01827 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1132,13 +1132,34 @@ if test "$enable_perlinterp" = "yes" -o "$enable_perlinterp" = "dynamic"; then
vi_cv_perllib=`$vi_cv_path_perl -MConfig -e 'print $Config{privlibexp}'`
AC_SUBST(vi_cv_perllib)
vi_cv_perl_extutils=unknown_perl_extutils_path
- for extutils_rel_path in ExtUtils vendor_perl/ExtUtils; do
- xsubpp_path="$vi_cv_perllib/$extutils_rel_path/xsubpp"
- if test -f "$xsubpp_path"; then
- vi_cv_perl_xsubpp="$xsubpp_path"
- fi
- done
+
+ AC_MSG_CHECKING(--with-xsubpp path)
+ vi_cv_perl_xsubpp=
+ AC_ARG_WITH(xsubpp, [ --with-xsubpp=PATH path to the xsubpp command], [
+ if test -f "$withval"
+ then
+ vi_cv_perl_xsubpp="$withval"
+ fi
+ ])
+
+ if test "x$vi_cv_perl_xsubpp" = "x"
+ then
+ for extutils_rel_path in ExtUtils vendor_perl/ExtUtils; do
+ xsubpp_path="$vi_cv_perllib/$extutils_rel_path/xsubpp"
+ if test -f "$xsubpp_path"; then
+ vi_cv_perl_xsubpp="$xsubpp_path"
+ fi
+ done
+ fi
+
+ if test "x$vi_cv_perl_xsubpp" = "x"
+ then
+ AC_MSG_RESULT(empty)
+ else
+ AC_MSG_RESULT($vi_cv_perl_xsubpp)
+ fi
AC_SUBST(vi_cv_perl_xsubpp)
+
dnl Remove "-fno-something", it breaks using cproto.
dnl Remove "-fdebug-prefix-map", it isn't supported by clang.
dnl Remove "FORTIFY_SOURCE", it will be defined twice.