summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2021-01-30 19:33:36 +0100
committerBram Moolenaar <Bram@vim.org>2021-01-30 19:33:36 +0100
commitebd211c8a39871c88189c8cda9e624eb30b300b3 (patch)
tree7ad76c97dc7154e476c8fc20e972eac48091b367 /src/configure.ac
parentf8c6a1718007432812184c28495e8d27ee6c0395 (diff)
patch 8.2.2431: warning for -fno-strength-reduce with Clang 11v8.2.2431
Problem: Warning for -fno-strength-reduce with Clang 11. Solution: Adjust check for clang version number.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index fe2a401342..e511b35082 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -127,8 +127,9 @@ if test x"$CLANG_VERSION_STRING" != x"" ; then
dnl change the constant 500002075 below appropriately. To get the
dnl integer corresponding to a version number, refer to the
dnl definition of CLANG_VERSION above.
+ dnl Clang 11 reports "11", assume Clang 10 and later work like this.
AC_MSG_CHECKING(if clang supports -fno-strength-reduce)
- if test "$CLANG_VERSION" -ge 500002075 ; then
+ if test "$CLANG_MAJOR" -ge 10 -o "$CLANG_VERSION" -ge 500002075 ; then
AC_MSG_RESULT(no)
CFLAGS=`echo "$CFLAGS" | sed -e 's/-fno-strength-reduce/ /'`
else