summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorYee Cheng Chin <ychin.git@gmail.com>2023-09-16 13:38:26 +0200
committerChristian Brabandt <cb@256bit.org>2023-09-16 13:38:26 +0200
commite7d79eb98a30c529cf53fb4852a71b9fd1336c41 (patch)
tree4cae8697f68ddc6222ed6e652727c6fbbd8ac0e7 /src/configure.ac
parentffb13674d1af1c90beb229867ec989e4fb232df3 (diff)
patch 9.0.1900: Configure script uses non-portable == comparisonv9.0.1900
Problem: Configure script uses non-portable == comparison Solution: Use the standard and portable "=" instead closes: #13095 closes: #13099 Signed-off-by: Christian Brabandt <cb@256bit.org> Co-authored-by: Yee Cheng Chin <ychin.git@gmail.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 1a4dd5c50a..bfdcfea4d2 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1511,7 +1511,7 @@ if test "$enable_python3interp" = "yes" -o "$enable_python3interp" = "dynamic";
vi_cv_var_python3_stable_abi_hex=`
${vi_cv_path_python3} -c \
"major_minor='${vi_cv_var_python3_stable_abi}'.split('.'); print('0x{0:X}'.format( (int(major_minor.__getitem__(0))<<24) + (int(major_minor.__getitem__(1))<<16) ))"` ])
- if test "X$vi_cv_var_python3_stable_abi_hex" == "X"; then
+ if test "X$vi_cv_var_python3_stable_abi_hex" = "X"; then
AC_MSG_ERROR([can't parse Python 3 stable ABI version. It should be "<major>.<minor>"])
fi
fi