summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorRestorerZ <restorer@mail2k.ru>2024-03-12 22:11:36 +0100
committerChristian Brabandt <cb@256bit.org>2024-03-12 22:14:39 +0100
commite498cafe74e9073a9f8134f04c22b61d7bc68894 (patch)
tree33fd95ffb3a3027e87e3913e2a6b47418b7febb5 /src/configure.ac
parent9a660d2883f92b3a3761c964dc14363a8f70c8d8 (diff)
patch 9.1.0173: msgfmt ver. 0.22 forcibly converts text to UTF-8v9.1.0173
Problem: msgfmt ver. 0.22 forcibly converts text to UTF-8 Solution: use '--no-convert' if msgfmt supports it. Add a configure check for the msgfmt version (RestorerZ). closes: #14163 Co-authored-by: Christian Brabandt <cb@256bit.org> Signed-off-by: RestorerZ <restorer@mail2k.ru> Signed-off-by: Christian Brabandt <cb@256bit.org>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 664f219405..6311269e15 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4523,6 +4523,15 @@ if test "$enable_nls" = "yes"; then
AC_MSG_RESULT([no])
fi
AC_SUBST(MSGFMT_DESKTOP)
+ AC_MSG_CHECKING([if msgfmt supports --no-convert])
+ if "$MSGFMT" --help | grep -q -- '--no-convert' >/dev/null; then
+ AC_MSG_RESULT([yes])
+ MSGFMTCMD="OLD_PO_FILE_INPUT=yes msgfmt --no-convert -v"
+ else
+ AC_MSG_RESULT([no])
+ MSGFMTCMD="OLD_PO_FILE_INPUT=yes msgfmt -v"
+ fi
+ AC_SUBST(MSGFMTCMD)
fi
else
AC_MSG_RESULT([no "po/Makefile" - disabled]);