summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorIllia Bobyr <illia.bobyr@gmail.com>2023-09-30 22:59:27 +0200
committerChristian Brabandt <cb@256bit.org>2023-09-30 22:59:27 +0200
commite379e21ddc2dc12abea9dcfd0708e27788bb568c (patch)
treef28aecdd9d8c462c21d4d73d482d06e5ba2b0b03 /src/configure.ac
parent8c358e024fbc11895efec4b3e0e3777a6b88eba7 (diff)
patch 9.0.1966: configure prints stray 6 when checking librubyv9.0.1966
Problem: configure prints stray 6 when checking libruby Solution: redirect stdout to dev/null configure: Do not print "6" when checking for libruby `expr` will print the matched string length to the standard output. Current `configure` output looks like this: ``` checking Ruby header files... /usr/include/ruby-3.1.0 6 ``` The script really only cares about `expr` exit code. closes: #13234 Signed-off-by: Christian Brabandt <cb@256bit.org> Co-authored-by: Illia Bobyr <illia.bobyr@gmail.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4b2046dd52..dfbe512371 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2077,7 +2077,7 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
librubyarg=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBYARG']])"`
librubya=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBY_A']])"`
rubylibdir=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['libdir']])"`
- if test -f "$rubylibdir/$librubya" || expr "$librubyarg" : "-lruby"; then
+ if test -f "$rubylibdir/$librubya" || expr "$librubyarg" : "-lruby" >/dev/null; then
RUBY_LIBS="$RUBY_LIBS -L$rubylibdir"
elif test "$librubyarg" = "libruby.a"; then
dnl required on Mac OS 10.3 where libruby.a doesn't exist