summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2020-12-06 21:11:31 +0100
committerBram Moolenaar <Bram@vim.org>2020-12-06 21:11:31 +0100
commitd5a986f460019a924627d79350552f446505cffb (patch)
tree96feeb0596dd12fbbd41a0abe6d2a1e949e8c46f /src/configure.ac
parent41d6196e302af5f1a99aeeac587b5c662c410166 (diff)
patch 8.2.2104: build problem with Ruby 2.7v8.2.2104
Problem: Build problem with Ruby 2.7. Solution: Adjust function declarations. (Ozaki Kiichi, closes #7430)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4b6794a29e..062c75a20a 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1965,8 +1965,7 @@ if test "$enable_rubyinterp" = "yes" -o "$enable_rubyinterp" = "dynamic"; then
librubyarg=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBYARG']])"`
librubya=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBY_A']])"`
rubylibdir=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['libdir']])"`
- if test -f "$rubylibdir/$librubya"; then
- librubyarg="$librubyarg"
+ if test -f "$rubylibdir/$librubya" || expr "$librubyarg" : "-lruby"; then
RUBY_LIBS="$RUBY_LIBS -L$rubylibdir"
elif test "$librubyarg" = "libruby.a"; then
dnl required on Mac OS 10.3 where libruby.a doesn't exist