summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorChristian Brabandt <cb@256bit.org>2023-08-24 08:15:38 +0200
committerChristian Brabandt <cb@256bit.org>2023-08-24 08:15:38 +0200
commitd42f95bbfb5abcc78a0cc99f326691f328a2f33e (patch)
tree1d4d1c8b4f6e53187deca55fb1cf4607c737f171 /src/configure.ac
parent2f25e40b1f545f4aa38377f0c25effb112b5d1ef (diff)
patch 9.0.1787: Cannot build with latest luajitv9.0.1787
Problem: Cannot build with latest luajit Solution: adjust sed regexp and don't expect '-' in version output closes: #12896 Signed-off-by: Christian Brabandt <cb@256bit.org>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index cefd0c3b31..6813d76857 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -638,7 +638,7 @@ if test "$enable_luainterp" = "yes" -o "$enable_luainterp" = "dynamic"; then
if test "X$vi_cv_path_luajit" != "X"; then
dnl -- find LuaJIT version
AC_CACHE_CHECK(LuaJIT version, vi_cv_version_luajit,
- [ vi_cv_version_luajit=`${vi_cv_path_luajit} -v 2>&1 | sed 's/LuaJIT \([[0-9.]]*\)\.[[0-9]]\(-[[a-z0-9]]*\)* .*/\1/'` ])
+ [ vi_cv_version_luajit=`${vi_cv_path_luajit} -v 2>&1 | sed 's/LuaJIT \([[0-9.]]*\)\.[[0-9]]\(-\?[[a-z0-9]]*\)* .*/\1/'` ])
AC_CACHE_CHECK(Lua version of LuaJIT, vi_cv_version_lua_luajit,
[ vi_cv_version_lua_luajit=`${vi_cv_path_luajit} -e "print(_VERSION)" | sed 's/.* //'` ])
vi_cv_path_lua="$vi_cv_path_luajit"