summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorichizok <gclient.gaap@gmail.com>2023-08-29 20:54:32 +0200
committerChristian Brabandt <cb@256bit.org>2023-08-29 20:54:32 +0200
commitbddc6adca647f7f20ff6e1b7913e394d09c5eb23 (patch)
treef70c92dd5239c466e3255d036e36b9169286cc15 /src/configure.ac
parenta5eb6785efcc36a97e071722408acc20d6c6e606 (diff)
patch 9.0.1816: configure: sed uses non-portable regexv9.0.1816
Problem: configure: sed uses non-portable regex Solution: use '*' modifier instead of '\?' in regex for luajit version detection closes: #12954 Signed-off-by: Christian Brabandt <cb@256bit.org> Co-authored-by: ichizok <gclient.gaap@gmail.com>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 6a847222cc..c7e01f0b80 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -638,7 +638,7 @@ if test "$enable_luainterp" = "yes" -o "$enable_luainterp" = "dynamic"; then
if test "X$vi_cv_path_luajit" != "X"; then
dnl -- find LuaJIT version
AC_CACHE_CHECK(LuaJIT version, vi_cv_version_luajit,
- [ vi_cv_version_luajit=`${vi_cv_path_luajit} -v 2>&1 | sed 's/LuaJIT \([[0-9.]]*\)\.[[0-9]]\(-\?[[a-z0-9]]*\)* .*/\1/'` ])
+ [ vi_cv_version_luajit=`${vi_cv_path_luajit} -v 2>&1 | sed 's/LuaJIT \([[0-9.]]*\)\.[[0-9]]\(-*[[a-z0-9]]*\)* .*/\1/'` ])
AC_CACHE_CHECK(Lua version of LuaJIT, vi_cv_version_lua_luajit,
[ vi_cv_version_lua_luajit=`${vi_cv_path_luajit} -e "print(_VERSION)" | sed 's/.* //'` ])
vi_cv_path_lua="$vi_cv_path_luajit"