summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2021-11-19 11:28:04 +0000
committerBram Moolenaar <Bram@vim.org>2021-11-19 11:28:04 +0000
commitb3a29558eedac9979f5276ae914934b7b7cbe06b (patch)
tree574ec81a2f889213a6d049e5a6726ac8f30185fb /src/configure.ac
parent777175b0df8c5ec3cd30d19a2e887e661ac209c8 (diff)
patch 8.2.3620: memory leak reported in libtlibv8.2.3620
Problem: Memory leak reported in libtlib. Solution: Call del_curterm() when cleaning up memory. Rename term.h to termdefs.h to avoid a name clash.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 3316f48242..b4948e20e7 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3591,6 +3591,16 @@ AC_TRY_COMPILE([
AC_MSG_RESULT(yes); AC_DEFINE(HAVE_OUTFUNTYPE),
AC_MSG_RESULT(no))
+AC_MSG_CHECKING([whether del_curterm() can be used])
+AC_TRY_LINK([
+#ifdef HAVE_TERMCAP_H
+# include <termcap.h>
+#endif
+#include <term.h>
+ ], [if (cur_term) del_curterm(cur_term);],
+ AC_MSG_RESULT(yes); AC_DEFINE(HAVE_DEL_CURTERM),
+ AC_MSG_RESULT(no))
+
dnl On some SCO machines sys/select redefines struct timeval
AC_MSG_CHECKING([whether sys/select.h and sys/time.h may both be included])
AC_TRY_COMPILE([