summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorZdenek Dohnal <zdohnal@redhat.com>2023-01-09 13:18:08 +0000
committerBram Moolenaar <Bram@vim.org>2023-01-09 13:18:08 +0000
commit870cd76283e003a0fa57449aa077f0d01a6a2d80 (patch)
tree88f568d87dce80823f06d5abe81944762c8a048b /src/configure.ac
parentc8ab30a349ee45ef6c3b6af8ee5ff53d2f7bf891 (diff)
patch 9.0.1162: configure does not handle all FORTIFY_SOURCE variantsv9.0.1162
Problem: Configure does not handle all FORTIFY_SOURCE variants. Solution: Also handle Fedora's default FORTIFY_SOURCE flags. (Zdenek Dohnal, closes #11794)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/configure.ac b/src/configure.ac
index fc346dc811..93fbc32a7f 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4588,8 +4588,8 @@ if test "$GCC" = yes; then
dnl And undefine it first to avoid a warning.
AC_MSG_CHECKING(whether we need -D_FORTIFY_SOURCE=1)
if test "$gccmajor" -gt "3"; then
- CFLAGS=`echo "$CFLAGS" | sed -e 's/-D_FORTIFY_SOURCE=.,//g' -e 's/ *-Wp,-D_FORTIFY_SOURCE=. / /g' -e 's/,-D_FORTIFY_SOURCE=. //g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g' -e 's/$/ -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1/'`
- CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/-D_FORTIFY_SOURCE=.,//g' -e 's/ *-Wp,-D_FORTIFY_SOURCE=. / /g' -e 's/,-D_FORTIFY_SOURCE=. //g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g'`
+ CFLAGS=`echo "$CFLAGS" | sed -e 's/-D_FORTIFY_SOURCE=.,//g' -e 's/ *-Wp,-D_FORTIFY_SOURCE=. / /g' -e 's/,-D_FORTIFY_SOURCE=. //g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-Wp,-U_FORTIFY_SOURCE//g' -e 's/ *-U_FORTIFY_SOURCE//g' -e 's/$/ -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1/'`
+ CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/-D_FORTIFY_SOURCE=.,//g' -e 's/ *-Wp,-D_FORTIFY_SOURCE=. / /g' -e 's/,-D_FORTIFY_SOURCE=. //g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-Wp,-U_FORTIFY_SOURCE//g' -e 's/ *-U_FORTIFY_SOURCE//g'`
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)