summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2021-01-31 14:36:06 +0100
committerBram Moolenaar <Bram@vim.org>2021-01-31 14:36:06 +0100
commit4d8479b335e92a95b09fdee09309ea0df934cb9e (patch)
tree5f5ac3dba1b0604f44646be4fdaa5ba3282167df /src/configure.ac
parent206c2a6e19475ab664ca4cea3df8e42313d3a4c5 (diff)
patch 8.2.2437: deprecation warnings with default configurationv8.2.2437
Problem: Deprecation warnings with default configuration. Solution: Add -Wno-deprecated-declarations.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/configure.ac b/src/configure.ac
index e511b35082..630433f78a 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -90,7 +90,7 @@ with_x_arg="$with_x"
dnl Set default value for CFLAGS if none is defined or it's empty
if test -z "$CFLAGS"; then
CFLAGS="-O"
- test "$GCC" = yes && CFLAGS="-O2 -fno-strength-reduce -Wall"
+ test "$GCC" = yes && CFLAGS="-O2 -fno-strength-reduce -Wall -Wno-deprecated-declarations"
fi
if test "$GCC" = yes; then
dnl method that should work for nearly all versions