summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2021-09-06 18:57:30 +0200
committerBram Moolenaar <Bram@vim.org>2021-09-06 18:57:30 +0200
commit3ae5fc9a6a881e0be381e4cc70080ac5908d7520 (patch)
treedf2029485a6aedd48af0565556cd95d7e1eb3b3b /src/configure.ac
parentec1b0968aa90d408a79b5b5dca465f65e69753a1 (diff)
patch 8.2.3406: on some systems tests fail without _REENTRANTv8.2.3406
Problem: On some systems tests fail without _REENTRANT. (Elimar Riesebieter) Solution: Add -D_REENTRANT in configure. (closes #7402)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 5ec955757f..4cd6dea1f4 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4504,6 +4504,12 @@ if test "$MACOS_X" = "yes"; then
fi
fi
+dnl On some systems REENTRANT needs to be defined. It should not hurt to use
+dnl it everywhere.
+if `echo "$CFLAGS" | grep -v D_REENTRANT >/dev/null`; then
+ CFLAGS="$CFLAGS -D_REENTRANT"
+fi
+
dnl gcc 3.1 changed the meaning of -MM. The only solution appears to be to
dnl use "-isystem" instead of "-I" for all non-Vim include dirs.
dnl But only when making dependencies, cproto and lint don't take "-isystem".