summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2022-02-23 18:07:38 +0000
committerBram Moolenaar <Bram@vim.org>2022-02-23 18:07:38 +0000
commit33fc4a63071c03ad46636b345a814e7e6d8f4ae0 (patch)
treefd13574895afeebf6d0a17f2bcfdd5b985a231d9 /src/configure.ac
parentdd2dfb3cb00d47d2e8248c4e9d2cdf51e1574b79 (diff)
patch 8.2.4457: the GPM library can only be linked staticallyv8.2.4457
Problem: The GPM library can only be linked statically. Solution: Make it possible to load the GPM library dynamically. (Damien)
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac16
1 files changed, 10 insertions, 6 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 67b376a49e..4dd74fc2a8 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4096,13 +4096,13 @@ if test "x$GTK_CFLAGS" != "x"; then
LIBS="$ac_save_LIBS"
fi
-AC_MSG_CHECKING(--disable-gpm argument)
+AC_MSG_CHECKING(--enable-gpm argument)
AC_ARG_ENABLE(gpm,
- [ --disable-gpm Don't use gpm (Linux mouse daemon).], ,
+ [ --enable-gpm=OPTS Use gpm (Linux mouse daemon). default=yes OPTS=yes/no/dynamic], ,
[enable_gpm="yes"])
-if test "$enable_gpm" = "yes"; then
- AC_MSG_RESULT(no)
+if test "$enable_gpm" = "yes" -o "$enable_gpm" = "dynamic"; then
+ AC_MSG_RESULT($enable_gpm)
dnl Checking if gpm support can be compiled
AC_CACHE_CHECK([for gpm], vi_cv_have_gpm,
[olibs="$LIBS" ; LIBS="-lgpm"]
@@ -4117,11 +4117,15 @@ if test "$enable_gpm" = "yes"; then
[LIBS="$olibs"]
)
if test $vi_cv_have_gpm = yes; then
- LIBS="$LIBS -lgpm"
+ if test "$enable_gpm" = "yes"; then
+ LIBS="$LIBS -lgpm"
+ else
+ AC_DEFINE(DYNAMIC_GPM)
+ fi
AC_DEFINE(HAVE_GPM)
fi
else
- AC_MSG_RESULT(yes)
+ AC_MSG_RESULT(no)
fi
AC_MSG_CHECKING(--disable-sysmouse argument)