summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorBram Moolenaar <Bram@vim.org>2022-03-08 13:32:37 +0000
committerBram Moolenaar <Bram@vim.org>2022-03-08 13:32:37 +0000
commit0b40d086b337f14fdd0dbc035988ffb0aec8ce5f (patch)
treee20ea72f531fcef293dcddd49a2756e1a5d25ff9 /src/configure.ac
parent8acb9cc6209768ca7ec75c9f7af8c389312ea8d6 (diff)
patch 8.2.4527: the Athena GUI is old and does not work wellv8.2.4527
Problem: The Athena GUI is old and does not work well. Solution: Remove the Athena GUI from configure to find out who still wants support for this GUI.
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac52
1 files changed, 7 insertions, 45 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 4dd74fc2a8..68fa87ef55 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -291,8 +291,8 @@ if test "$vim_cv_uname_output" = Darwin; then
CPPFLAGS="$CPPFLAGS -DMACOS_X_DARWIN"
dnl Assume we don't want X11 unless it was specifically asked for
- dnl (--with-x) or Motif, Athena or GTK GUI is used.
- if test -z "$with_x" -a "X$enable_gui" != Xmotif -a "X$enable_gui" != Xathena -a "X$enable_gui" != Xgtk2 -a "X$enable_gui" != Xgtk3; then
+ dnl (--with-x) or Motif or GTK GUI is used.
+ if test -z "$with_x" -a "X$enable_gui" != Xmotif -a "X$enable_gui" != Xgtk2 -a "X$enable_gui" != Xgtk3; then
with_x=no
fi
fi
@@ -2443,7 +2443,7 @@ test "x$with_x" = xno -a "x$HAIKU" != "xyes" -a "x$MACOS_X" != "xyes" -a "x$QNX"
AC_MSG_CHECKING(--enable-gui argument)
AC_ARG_ENABLE(gui,
- [ --enable-gui[=OPTS] X11 GUI. [default=auto] [OPTS=auto/no/gtk2/gnome2/gtk3/motif/athena/neXtaw/haiku/photon/carbon]], , enable_gui="auto")
+ [ --enable-gui[=OPTS] X11 GUI. [default=auto] [OPTS=auto/no/gtk2/gnome2/gtk3/motif/neXtaw/haiku/photon/carbon]], , enable_gui="auto")
dnl Canonicalize the --enable-gui= argument so that it can be easily compared.
dnl Do not use character classes for portability with old tools.
@@ -2455,7 +2455,6 @@ SKIP_GTK2=YES
SKIP_GTK3=YES
SKIP_GNOME=YES
SKIP_MOTIF=YES
-SKIP_ATHENA=YES
SKIP_NEXTAW=YES
SKIP_PHOTON=YES
SKIP_HAIKU=YES
@@ -2502,7 +2501,6 @@ else
SKIP_GTK3=
SKIP_GNOME=
SKIP_MOTIF=
- SKIP_ATHENA=
SKIP_NEXTAW=;;
gtk2) AC_MSG_RESULT(GTK+ 2.x GUI support)
SKIP_GTK2=;;
@@ -2513,8 +2511,6 @@ else
SKIP_GTK3=;;
motif) AC_MSG_RESULT(Motif GUI support)
SKIP_MOTIF=;;
- athena) AC_MSG_RESULT(Athena GUI support)
- SKIP_ATHENA=;;
nextaw) AC_MSG_RESULT(neXtaw GUI support)
SKIP_NEXTAW=;;
*) AC_MSG_RESULT([Sorry, $enable_gui GUI is not supported]) ;;
@@ -2568,17 +2564,6 @@ if test "x$SKIP_MOTIF" != "xYES" -a "$enable_gui_canon" != "motif"; then
fi
fi
-if test "x$SKIP_ATHENA" != "xYES" -a "$enable_gui_canon" != "athena"; then
- AC_MSG_CHECKING(whether or not to look for Athena)
- AC_ARG_ENABLE(athena-check,
- [ --enable-athena-check If auto-select GUI, check for Athena [default=yes]],
- , enable_athena_check="yes")
- AC_MSG_RESULT($enable_athena_check)
- if test "x$enable_athena_check" = "xno"; then
- SKIP_ATHENA=YES
- fi
-fi
-
if test "x$SKIP_NEXTAW" != "xYES" -a "$enable_gui_canon" != "nextaw"; then
AC_MSG_CHECKING(whether or not to look for neXtaw)
AC_ARG_ENABLE(nextaw-check,
@@ -2821,7 +2806,6 @@ if test -z "$SKIP_GTK2"; then
GUI_INC_LOC="$GTK_CFLAGS"], )
if test "x$GTK_CFLAGS" != "x"; then
SKIP_GTK3=YES
- SKIP_ATHENA=YES
SKIP_NEXTAW=YES
SKIP_MOTIF=YES
GUITYPE=GTK
@@ -2872,7 +2856,6 @@ if test -z "$SKIP_GTK3"; then
if test "x$GTK_CFLAGS" != "x"; then
SKIP_GTK2=YES
SKIP_GNOME=YES
- SKIP_ATHENA=YES
SKIP_NEXTAW=YES
SKIP_MOTIF=YES
GUITYPE=GTK
@@ -3034,32 +3017,11 @@ if test -z "$SKIP_MOTIF"; then
fi
if test -z "$SKIP_MOTIF"; then
- SKIP_ATHENA=YES
SKIP_NEXTAW=YES
GUITYPE=MOTIF
AC_SUBST(MOTIF_LIBNAME)
fi
-dnl Check if the Athena files can be found
-
-GUI_X_LIBS=
-
-if test -z "$SKIP_ATHENA"; then
- AC_MSG_CHECKING(if Athena header files can be found)
- cflags_save=$CFLAGS
- CFLAGS="$CFLAGS $X_CFLAGS"
- AC_TRY_COMPILE([
-#include <X11/Intrinsic.h>
-#include <X11/Xaw/Paned.h>], ,
- AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no); SKIP_ATHENA=YES )
- CFLAGS=$cflags_save
-fi
-
-if test -z "$SKIP_ATHENA"; then
- GUITYPE=ATHENA
-fi
-
if test -z "$SKIP_NEXTAW"; then
AC_MSG_CHECKING(if neXtaw header files can be found)
cflags_save=$CFLAGS
@@ -3076,7 +3038,7 @@ if test -z "$SKIP_NEXTAW"; then
GUITYPE=NEXTAW
fi
-if test -z "$SKIP_ATHENA" -o -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF"; then
+if test -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF"; then
dnl Prepend -I and -L to $GUI_INC_LOC and $GUI_LIB_LOC if not empty
dnl Avoid adding it when it twice
if test -n "$GUI_INC_LOC"; then
@@ -3138,7 +3100,7 @@ if test "$enable_xsmp" = "yes"; then
fi
-if test -z "$SKIP_ATHENA" -o -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF" -o -z "$SKIP_GTK2" -o -z "$SKIP_GTK3"; then
+if test -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF" -o -z "$SKIP_GTK2" -o -z "$SKIP_GTK3"; then
dnl Check for X11/xpm.h and X11/Sunkeysym.h with the GUI include path
cppflags_save=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $X_CFLAGS"
@@ -3160,7 +3122,7 @@ if test -z "$SKIP_ATHENA" -o -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF" -o -z "$SKIP_
fi
fi
-if test -z "$SKIP_ATHENA" -o -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF"; then
+if test -z "$SKIP_NEXTAW" -o -z "$SKIP_MOTIF"; then
cppflags_save=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $X_CFLAGS"
dnl Xmu/Editres.h may exist but can only be used after including Intrinsic.h
@@ -3175,7 +3137,7 @@ dnl Xmu/Editres.h may exist but can only be used after including Intrinsic.h
CPPFLAGS=$cppflags_save
fi
-dnl Only use the Xm directory when compiling Motif, don't use it for Athena
+dnl Only use the Xm directory when compiling Motif.
if test -z "$SKIP_MOTIF"; then
cppflags_save=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $X_CFLAGS"