summaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
authorChrist van Willegen <cvwillegen@gmail.com>2024-06-20 23:41:59 +0200
committerChristian Brabandt <cb@256bit.org>2024-06-20 23:41:59 +0200
commitce0ef910df837b9b961f007a0a35064cad85188b (patch)
treebd8b18ad704b6166904c78b706b1a4e359e3124b /src/configure.ac
parentf7f8f0b76dc6a3bf5d51825db65245221e5d265e (diff)
patch 9.1.0509: not possible to translate Vim script messagesv9.1.0509
Problem: not possible to translate Vim script messages (RestorerZ) Solution: implement bindtextdomain() and gettext() to support Vim script message translations (Christ van Willegen) fixes: #11637 closes: #12447 Signed-off-by: Christ van Willegen <cvwillegen@gmail.com> Signed-off-by: Christian Brabandt <cb@256bit.org>
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 946fe52ffe..29cd926b56 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4497,6 +4497,12 @@ if test "$enable_nls" = "yes"; then
AC_SUBST(MAKEMO)
dnl this was added in GNU gettext 0.10.36
AC_CHECK_FUNCS(bind_textdomain_codeset)
+ AC_MSG_CHECKING([for dgettext])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
+ [#include <libintl.h>],
+ [dgettext("Test", "Test");])],
+ AC_MSG_RESULT([yes]); AC_DEFINE(HAVE_DGETTEXT),
+ AC_MSG_RESULT([no]))
dnl _nl_msg_cat_cntr is required for GNU gettext
AC_MSG_CHECKING([for _nl_msg_cat_cntr])
AC_LINK_IFELSE([AC_LANG_PROGRAM(