summaryrefslogtreecommitdiffstats
path: root/tokio-fs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tokio-fs/Cargo.toml')
-rw-r--r--tokio-fs/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/tokio-fs/Cargo.toml b/tokio-fs/Cargo.toml
index 59d2ae57..10090fef 100644
--- a/tokio-fs/Cargo.toml
+++ b/tokio-fs/Cargo.toml
@@ -24,9 +24,10 @@ categories = ["asynchronous", "network-programming", "filesystem"]
publish = false
[dependencies]
-futures = "0.1.21"
+futures-core-preview = "0.3.0-alpha.17"
tokio-threadpool = { version = "0.2.0", path = "../tokio-threadpool" }
tokio-io = { version = "0.2.0", path = "../tokio-io" }
+tokio-futures = { version = "0.2.0", path = "../tokio-futures" }
[dev-dependencies]
rand = "0.6"
@@ -34,3 +35,6 @@ tempfile = "3"
tempdir = "0.3"
tokio-codec = { version = "0.2.0", path = "../tokio-codec" }
tokio = { version = "0.2.0", path = "../tokio" }
+futures-channel-preview = "0.3.0-alpha.17"
+futures-preview = { version = "0.3.0-alpha.17" }
+futures-util-preview = "0.3.0-alpha.17"