summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2020-09-24 10:51:46 -0700
committerGitHub <noreply@github.com>2020-09-24 10:51:46 -0700
commita1d0681cd2e581b1f6767126858d2f3d5d8992f5 (patch)
tree6f7b9aa5e4bd32854683a42753a145132e2ac7cc /tokio/Cargo.toml
parent4dfbdbff7e260eb7f046a8dc91ec0c84ae7ab2e8 (diff)
process: do not publicly turn on `signal` when enabled (#2871)
This change will still internally compile any `signal` resources required when `process` is enabled on unix systems, but it will not publicly turn on the cargo feature
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 6df368eb..0296e279 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -59,10 +59,11 @@ macros = ["tokio-macros"]
net = ["dns", "tcp", "udp", "uds"]
process = [
"io-driver",
+ "lazy_static",
"libc",
"mio-named-pipes",
- "signal",
- "winapi/consoleapi",
+ "mio-uds",
+ "signal-hook-registry",
"winapi/threadpoollegacyapiset",
]
# Includes basic task execution capabilities