summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorbdonlan <bdonlan@gmail.com>2020-10-05 14:25:04 -0700
committerGitHub <noreply@github.com>2020-10-05 14:25:04 -0700
commit9730317e94cd5bfca237376549405a6feb815223 (patch)
tree333c03937b5c804b4c79335cdb8d7d68cf665e44 /tokio/Cargo.toml
parent02311dcfa13d719c3f591c922f8a719d7c954ef0 (diff)
time: move DelayQueue to tokio-util (#2897)
This change is intended to do the minimum to unblock 0.3; as such, for now, we duplicate the internal `time::wheel` structures in tokio-util, rather than trying to refactor things at this stage. Co-authored-by: Bryan Donlan <bdonlan@amazon.com>
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index fdce440f..6d8377c2 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -83,7 +83,7 @@ stream = ["futures-core"]
sync = ["fnv"]
test-util = []
tcp = ["lazy_static", "mio/tcp", "mio/os-poll"]
-time = ["slab"]
+time = []
udp = ["lazy_static", "mio/udp", "mio/os-poll"]
uds = ["lazy_static", "libc", "mio/uds", "mio/os-poll"]
@@ -101,7 +101,7 @@ memchr = { version = "2.2", optional = true }
mio = { version = "0.7.2", optional = true }
num_cpus = { version = "1.8.0", optional = true }
parking_lot = { version = "0.11.0", optional = true } # Not in full
-slab = { version = "0.4.1", optional = true } # Backs `DelayQueue`
+slab = { version = "0.4.1", optional = true }
tracing = { version = "0.1.16", default-features = false, features = ["std"], optional = true } # Not in full
[target.'cfg(unix)'.dependencies]