summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorTaiki Endo <te316e89@gmail.com>2020-10-13 03:36:26 +0900
committerGitHub <noreply@github.com>2020-10-13 03:36:26 +0900
commit891de3271dc3545fb09162e578251e9977d9789c (patch)
tree0c2b4f500c0bf7dc85a78d51ac4860130329d166 /tokio/Cargo.toml
parent8880222036f37c6204c8466f25e828447f16dacb (diff)
net: merge tcp, udp, uds features to net feature (#2943)
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index cb407f93..5b361e6b 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -52,7 +52,15 @@ io-util = ["memchr"]
# stdin, stdout, stderr
io-std = []
macros = ["tokio-macros"]
-net = ["dns", "tcp", "udp", "uds"]
+net = [
+ "dns",
+ "lazy_static",
+ "libc",
+ "mio/os-poll",
+ "mio/tcp",
+ "mio/udp",
+ "mio/uds",
+]
process = [
"lazy_static",
"libc",
@@ -80,10 +88,7 @@ signal = [
stream = ["futures-core"]
sync = ["fnv"]
test-util = []
-tcp = ["lazy_static", "mio/tcp", "mio/os-poll"]
time = []
-udp = ["lazy_static", "mio/udp", "mio/os-poll"]
-uds = ["lazy_static", "libc", "mio/uds", "mio/os-poll"]
[dependencies]
tokio-macros = { version = "0.3.0", path = "../tokio-macros", optional = true }