summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2020-09-06 20:30:40 -0700
committerGitHub <noreply@github.com>2020-09-07 03:30:40 +0000
commit842d5565bdd4310cd96386a8ffa9949b24c5856f (patch)
tree33ce4fd24247ad7b4e65a1341961580f4baf1af9 /tokio/Cargo.toml
parentd74eabc7d795afa8ca2cd9170977d47131e12ee0 (diff)
process: add Child::{wait,try_wait} (#2796)
* add Child::try_wait to mirror the std API * replace Future impl on Child with `.wait()` method to bring our APIs closer to those in std and it allow us to internally fuse the future so that repeated calls to `wait` result in the same value (similar to std) without forcing the caller to fuse the outer future * Also change `Child::id` to return an Option result to avoid allowing the caller to accidentally use the pid on Unix systems after the child has been reaped * Also remove deprecated Child methods
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml3
1 files changed, 0 insertions, 3 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 38d2d6f2..b1d943e3 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -63,9 +63,7 @@ process = [
"mio-named-pipes",
"signal",
"winapi/consoleapi",
- "winapi/minwindef",
"winapi/threadpoollegacyapiset",
- "winapi/winerror",
]
# Includes basic task execution capabilities
rt-core = ["slab"]
@@ -81,7 +79,6 @@ signal = [
"mio-uds",
"signal-hook-registry",
"winapi/consoleapi",
- "winapi/minwindef",
]
stream = ["futures-core"]
sync = ["fnv"]