summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorÉmile Grégoire <eg@emilegregoire.ca>2020-07-28 23:43:19 -0400
committerGitHub <noreply@github.com>2020-07-28 20:43:19 -0700
commit646fbae76535e397ef79dbcaacb945d4c829f666 (patch)
tree49c00b3825463cae83eef0e1b65ee3d8266980c3 /tokio/Cargo.toml
parent1562bb314482215eb7517e6b8b8bdecbacf10e79 (diff)
rt: fix potential leak during runtime shutdown (#2649)
JoinHandle of threads created by the pool are now tracked and properly joined at shutdown. If the thread does not return within the timeout, then it's not joined and left to the OS for cleanup. Also, break a cycle between wakers held by the timer and the runtime. Fixes #2641, #2535
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index eca1554a..966bfe3e 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -67,7 +67,7 @@ process = [
"winapi/winerror",
]
# Includes basic task execution capabilities
-rt-core = []
+rt-core = ["slab"]
rt-util = []
rt-threaded = [
"num_cpus",
@@ -129,7 +129,7 @@ proptest = "0.9.4"
tempfile = "3.1.0"
[target.'cfg(loom)'.dev-dependencies]
-loom = { version = "0.3.4", features = ["futures", "checkpoint"] }
+loom = { version = "0.3.5", features = ["futures", "checkpoint"] }
[package.metadata.docs.rs]
all-features = true