summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorIvan Petkov <ivanppetkov@gmail.com>2020-09-24 14:36:42 -0700
committerGitHub <noreply@github.com>2020-09-24 21:36:42 +0000
commit56acde069fe7fc57259e72de612f0c91c1320972 (patch)
treea06d5cad65375336dc93441a6f207e3de93fcefe /tokio/Cargo.toml
parentffa5bdb22db066b531e45b42d0cb236c3916eee2 (diff)
chore: remove internal io-driver cargo feature (#2881)
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml11
1 files changed, 5 insertions, 6 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 4d8edf63..9e7ebf12 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -50,16 +50,15 @@ full = [
blocking = ["rt-core"]
dns = ["rt-core"]
fs = ["rt-core", "io-util"]
-io-driver = ["mio", "lazy_static"] # internal only
io-util = ["memchr"]
# stdin, stdout, stderr
io-std = ["rt-core"]
macros = ["tokio-macros"]
net = ["dns", "tcp", "udp", "uds"]
process = [
- "io-driver",
"lazy_static",
"libc",
+ "mio",
"mio-named-pipes",
"mio-uds",
"signal-hook-registry",
@@ -73,9 +72,9 @@ rt-threaded = [
"rt-core",
]
signal = [
- "io-driver",
"lazy_static",
"libc",
+ "mio",
"mio-uds",
"signal-hook-registry",
"winapi/consoleapi",
@@ -83,10 +82,10 @@ signal = [
stream = ["futures-core"]
sync = ["fnv"]
test-util = []
-tcp = ["io-driver", "iovec"]
+tcp = ["iovec", "lazy_static", "mio"]
time = ["slab"]
-udp = ["io-driver"]
-uds = ["io-driver", "mio-uds", "libc"]
+udp = ["lazy_static", "mio"]
+uds = ["lazy_static", "libc", "mio", "mio-uds"]
[dependencies]
tokio-macros = { version = "0.3.0", path = "../tokio-macros", optional = true }