summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2020-10-12 16:06:02 -0700
committerGitHub <noreply@github.com>2020-10-12 16:06:02 -0700
commit19233508806ddf22a14acf944426e0da8a401df8 (patch)
tree5a204c0958ecc30f6ef05a464fb5446b398a7e46 /tokio/Cargo.toml
parentc90681bd8e629b5fde988b9f5be7b915e5cf8ae5 (diff)
meta: combine `net` and `dns`, use `parking_lot` (#2951)
This combines the `dns` and `net` feature flags. Previously, `dns` was included as part of `net`. Given that is is rare that one would want `dns` without `net`, DNS is now entirely gated w/ `net`. The `parking_lot` feature is included as part of `full`. Some misc docs are tweaked to reflect feature flag changes.
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 6b0c4d8c..53aa41e1 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -30,12 +30,12 @@ default = []
# enable everything
full = [
- "dns",
"fs",
"io-util",
"io-std",
"macros",
"net",
+ "parking_lot",
"process",
"rt",
"rt-multi-thread",
@@ -45,14 +45,12 @@ full = [
"time",
]
-dns = []
fs = []
io-util = ["memchr"]
# stdin, stdout, stderr
io-std = []
macros = ["tokio-macros"]
net = [
- "dns",
"lazy_static",
"libc",
"mio/os-poll",