summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Einwag <matthias.einwag@live.com>2020-05-02 14:19:28 -0700
committerGitHub <noreply@github.com>2020-05-02 14:19:28 -0700
commit187af2e6a323be4193c82ad95f9aa32d2ae16869 (patch)
tree1c7ffff79471905383b74aad7abcfcfc3e6e2b28 /tokio/Cargo.toml
parent31315b94638d8d5912c5f8321d365fd6a210a060 (diff)
sync: add CancellationToken (#2263)
As a first step towards structured concurrency, this change adds a CancellationToken for graceful cancellation of tasks. The task can be awaited by an arbitrary amount of tasks due to the usage of an intrusive list. The token can be cloned. In addition to this child tokens can be derived. When the parent token gets cancelled, all child tokens will also get cancelled.
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 063d208e..63bb7ac0 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -123,6 +123,7 @@ optional = true
[dev-dependencies]
tokio-test = { version = "0.2.0", path = "../tokio-test" }
futures = { version = "0.3.0", features = ["async-await"] }
+futures-test = "0.3.0"
proptest = "0.9.4"
tempfile = "3.1.0"