summaryrefslogtreecommitdiffstats
path: root/tokio/Cargo.toml
diff options
context:
space:
mode:
authorIban Eguia <razican@protonmail.ch>2020-12-04 10:23:13 +0100
committerGitHub <noreply@github.com>2020-12-04 10:23:13 +0100
commit0dbba139848de6a8ee88350cc7fc48d0b05016c5 (patch)
tree73f3366b9c7a0c50d6dd146a2626368cf59b3178 /tokio/Cargo.toml
parenta125ebd745f31098aa170cb1009ff0fe34508d37 (diff)
deps: replace lazy_static with once_cell (#3187)
Diffstat (limited to 'tokio/Cargo.toml')
-rw-r--r--tokio/Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/tokio/Cargo.toml b/tokio/Cargo.toml
index 15ba7179..ad56ef02 100644
--- a/tokio/Cargo.toml
+++ b/tokio/Cargo.toml
@@ -50,7 +50,6 @@ io-util = ["memchr", "bytes"]
io-std = []
macros = ["tokio-macros"]
net = [
- "lazy_static",
"libc",
"mio/os-poll",
"mio/os-util",
@@ -60,7 +59,7 @@ net = [
]
process = [
"bytes",
- "lazy_static",
+ "once_cell",
"libc",
"mio/os-poll",
"mio/os-util",
@@ -75,7 +74,7 @@ rt-multi-thread = [
"rt",
]
signal = [
- "lazy_static",
+ "once_cell",
"libc",
"mio/os-poll",
"mio/uds",
@@ -96,7 +95,7 @@ pin-project-lite = "0.2.0"
# Everything else is optional...
bytes = { version = "0.6.0", optional = true }
futures-core = { version = "0.3.0", optional = true }
-lazy_static = { version = "1.4.0", optional = true }
+once_cell = { version = "1.5.2", optional = true }
memchr = { version = "2.2", optional = true }
mio = { version = "0.7.6", optional = true }
num_cpus = { version = "1.8.0", optional = true }