summaryrefslogtreecommitdiffstats
path: root/tokio-util/Cargo.toml
diff options
context:
space:
mode:
authorCarl Lerche <me@carllerche.com>2019-11-22 15:55:10 -0800
committerGitHub <noreply@github.com>2019-11-22 15:55:10 -0800
commit7b4c999341809588a427a9a80d310ee4aa1c1a21 (patch)
tree13e7638b2ec0ad90fbdbaf4f7100d8a2f8841703 /tokio-util/Cargo.toml
parente1b1e216c506a01a1f4ca579adae02f85b8db82b (diff)
default all feature flags to off (#1811)
Changes the set of `default` feature flags to `[]`. By default, only core traits are included without specifying feature flags. This makes it easier for users to pick the components they need. For convenience, a `full` feature flag is included that includes all components. Tests are configured to require the `full` feature. Testing individual feature flags will need to be moved to a separate crate. Closes #1791
Diffstat (limited to 'tokio-util/Cargo.toml')
-rw-r--r--tokio-util/Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/tokio-util/Cargo.toml b/tokio-util/Cargo.toml
index 8e5542be..356712c6 100644
--- a/tokio-util/Cargo.toml
+++ b/tokio-util/Cargo.toml
@@ -19,6 +19,16 @@ Additional utilities for working with Tokio.
"""
categories = ["asynchronous"]
+[features]
+# No features on by default
+default = []
+
+# Shorthand for enabling everything
+full = ["codec", "udp"]
+
+codec = []
+udp = ["tokio/udp"]
+
[dependencies]
tokio = { version = "=0.2.0-alpha.6", path = "../tokio" }
@@ -29,10 +39,11 @@ log = "0.4"
pin-project-lite = "0.1.1"
[dev-dependencies]
-tokio = { version = "=0.2.0-alpha.6", path = "../tokio" }
+tokio = { version = "=0.2.0-alpha.6", path = "../tokio", features = ["full"] }
tokio-test = { version = "=0.2.0-alpha.6", path = "../tokio-test" }
futures = "0.3.0"
[package.metadata.docs.rs]
all-features = true
+rustdoc-args = ["--cfg", "docsrs"]